Morning
> The internet router is in port 1, the laptop is in port 5. I have now set
> the router port as a trunk on the switch.
>
> Port 5 is on a different subnet to port 1, the laptop is 10.1.202.0 and the
> router 10.1.201.0
>
> I set the static addresses of the laptop as follows:
> ip: 10.1.202.10
> subnet: 255.255.255.0
> gateway: 10.1.202.1 (this is the VLAN ip address, I have tried giving it the
> router ip address but it didn't work... maybe I should try the internet VLAN
> address?)
>
> It is so close to working!
>
>
I forgot the HP's had trunk (bonded) ports we had trouble with those
so did not use them with the latest firmware, I was referring to Vlan
trunks. Vlans will not be active until one of the un-tagged ports is
up (something connected to it)
Anyways this is how I would configure it.
Port 1 on the switch would be the vlan trunk port, this means it needs
to be a member of all the vlans as a tagged port and will be connected
to your router.
vlan 2
name "INTERNET"
untagged 2-5
ip address 10.1.201.2 255.255.255.0
tagged 1
exit
vlan 3
name "RESIDENTS"
untagged 6-24
ip address 10.1.202.2 255.255.255.0
tagged 1
exit
vlan 4
name "TEST"
untagged 25-48
ip address 10.1.205.3 255.255.255.0
tagged T1
exit
Dlink. I has never used one of these but in the Cisco world the
config would look like this
interface FastEthernet0/0
description Trunk to HP switch
no ip address
full-duplex
interface FastEthernet0/0.2
description INTERNET vlan
encapsulation dot1Q 2
ip address 10.1.201.1 255.255.255.0
interface FastEthernet0/0.3
description RESIDENTS vlan
encapsulation dot1Q 3
ip address 10.1.202.1 255.255.255.0
interface FastEthernet0/0.4
description TEST vlan
encapsulation dot1Q 4
ip address 10.1.205.1 255.255.255.0
The above configs leave all routing to the router and switching to the
switch, the default gateway for any hosts will be the router's IP
--
Please post to: Hampshire@???
Web Interface:
https://mailman.lug.org.uk/mailman/listinfo/hampshire
LUG URL:
http://www.hantslug.org.uk
--------------------------------------------------------------